[Aboriginal] /usr/src <-> README mismatch

Tim Bird tbird20d at gmail.com
Wed Aug 13 16:58:09 PDT 2014

Hey Rob,

I've been playing around with aboriginal, and I noticed a discrepancy between
the contents of /usr/src (for system-image-armv6l) and the online README.

The README says you can do:

cc /usr/src/hello.c

but there is no hello.c in /usr/src:

(armv6l:1) /home # ls /usr/src
MANIFEST       config-linux  hello.cpp thread-hello.c
config-busybox config-uClibc host-info thread-hello2.c

I tried "cc /usr/src/thread-hello.c" and got the following:

(armv6l:1) /home # cc /usr/src/thread-hello.c
/tmp/cc42f7aq.o: In function `main':
thread-hello.c:(.text+0x58): undefined reference to `pthread_create'

I tried "cpp /usr/src/hello.cpp", and got this:

/home # cpp /usr/src/hello.cpp
# 1 "/usr/src/hello.cpp"
# 1 "<built-in>"
# 1 "<command-line>"
# 1 "/usr/src/hello.cpp"
/usr/src/hello.cpp:1:20: error: iostream: No such file or directory

using namespace std;

int main()
    cout << "hello world" << endl;
    return 0;

I wrote my own hello.c in my home directory, and things worked fine.

None of this is major stuff - just a slight discrepancy between the image
contents and the README, but I thought I'd report it anyhow.

Thanks for all your great work!

 -- Tim Bird
Senior Software Engineer, Sony Mobile
Architecture Group Chair, CE Workgroup, Linux Foundation

More information about the Aboriginal mailing list