[Aboriginal] Unable to use gcc inside chroot of latest aboriginal.

Rob Landley rob at landley.net
Sat Jan 16 22:53:34 PST 2016

On 01/16/2016 08:57 AM, KARBOWSKI Piotr wrote:
> Hi, On 01/11/2016 02:00 AM, Rob Landley wrote:
>> How are you combining the two?
> I tried cp -a, cp -al, rsync -a and every time I am getting the same issue.
> To reproduce the issue one can just:
> 1. fetch aboriginal hg.
> 2. run ./build.sh x86_64
> 3. jump to root
> 4. mkdir foo && cd foo
> 5. cp -al ../build/root-filesystem-x86.64/. .
> 6. cp -al ../build/native-compiler-x86_64/. .
> 7. chroot . /bin/sh
> 8. run gcc

You didn't run sbin/init.sh so your path didn't get set.

> I tried also env -i chroot . /bin/bash --login, and then export PATH
> (because PATH was set, but not exported) but still the same issue.
> rawcc: No such file or directory.

Yeah, poking at it earlier today I stopped at the "path not exported"
part, but looking at it again with the default PATH=/bin:/sbin it's
working, but with /usr/bin/gcc being found first, the relative paths
aren't set up right. Hmmm... strace is finding:

execve("(null)/bin/rawcc", ["rawcc"], [/* 16 vars */]) = -1 ENOENT (No
such file or directory)

Which clearly isn't right; something's gone pear shaped and topdir isn't
set. (There's an explicit test for that, so it got unset _after_ that
test... Hmmm...)

So yes, by intentionally ignoring the working examples provided
(more/setup-chroot.sh and such), you did indeed find a bug. Thanks for
the heads up.



More information about the Aboriginal mailing list