[Aboriginal] Latest cross-compiler-x86_64 stopped working as /usr/bin/x86-64-gcc symlink

Denys Vlasenko vda.linux at googlemail.com
Mon Jan 30 13:48:26 PST 2017

Hi Rob,

Needing to test some musl glob() issues, today I downloaded


I unpacked it into /some/directory, then made it available

ln -sf /some/directory/bin/* /usr/bin

This used to work: I have a much older installation
in /some/fwl_x_glibc_x8664_uclibc_x8664-0.9.11,
and for it this procedure works. After it:

$ x86_64-gcc
rawcc: no input files

That is, it found /some/fwl*/x86_64-unknown-linux/bin/rawcc

But for the one I downloaded today, it does not work:
$ x86_64-gcc
rawcc: No such file or directory

It appears it does not like being a symlink:

$ /usr/bin/x86_64-gcc
rawcc: No such file or directory   // still no go

$ ls -l /usr/bin/x86_64-gcc
lrwxrwxrwx 1 root root 55 Jan 30 22:43 /usr/bin/x86_64-gcc ->

$ /usr/app/aboriginal-20170130-cross-x8664/bin/x86_64-gcc
rawcc: no input files     // OK, now it works

More information about the Aboriginal mailing list