[Aboriginal] does anyone know how to get the m68k prebuilt binary to run

Rob Landley rob at landley.net
Mon Apr 18 11:04:08 PDT 2011

On 04/18/2011 12:30 PM, sean symons wrote:
> I haven't been able to get the m68k prebuilt binary to run right,

Charles Stevens got it to run under the emulator Aranym, but it involved
a largeish patch to the kernel to add support for aranym's
paravirtualized devices.  (I've cc'd him.)

> I found the run-emulator.sh script was blank and put the appropriate
> syntax in to run the script and nothing happened.

Unfortunately, QEMU only emulates coldfire, which is a nommu m68k subset
that doesn't implement the full instruction set.

People were working on adding full m68k support to qemu:


But I honestly haven't been keeping up...

> The next step I took
> was to proceed to qemu's wiki and used their test ucilinux m68k kernel
> which ran with the script but is lacking on the modules required to
> mount the squashfs image that is in the m68k prebuilt binary zip i
> Downloaded from Landley.net.

Charles told me that the root filesystem worked fine under aranym, which
means the cross compiler and C library worked.  (Although current source
control has uClibc 0.9.32-rc3 which breaks all sorts of stuff and needs
a lot of regression testing with a very large hammer.)

The kernel we're building never worked, he patched one to get it to work
and I could probably dig up his patch if necessary.

> I may have to move forward and cross
> compile my own m68k kernel but before I did I was wondering if anybody
> else was able to make this work, thanks in advance.

Not under qemu. but I haven't tried in over a year.  (I'm happy to
follow up on other people's interest, but really I wanna get _qemu_ to
work, and I'm not up to adding a whole architecture to QEMU which I only
ever wrote one assembly language program for, and that was 15 years ago...)



More information about the Aboriginal mailing list