[Aboriginal] Release 1.0.2 is uploading.

Rob Landley rob at landley.net
Tue Jun 14 18:56:17 PDT 2011

Ok, I got just about all the targets working.  The only ones that don't
pass the hello world smoketest (it natively compiles and runs a threaded
hello world program) are armv4eb (which qemu doesn't emulate), m68k
(ditto), mips64 (which doesn't even ls -l without showing bugs) and
sparc (which is static only and building -lpthreads static is a
dependency nightmare between libc and libpthreads, I should poke the
qemu guys about that but not today).  Everything else that _was_ broken
is fixed, including armv6l, sh4, and mips.

Even powerpc-440fp worked, which it shouldn't.  (I migrated powerpc to
use baseconfig, which yanked the old ppc440 symlink dependency, meaning
the ppc440 config is baseconfig-linux with no arch-specific additions,
yet it booted.  Huh?  with zero platform specific lines, the DEFAULTS
worked?  Not questioning it.  I need to do a proper -M bamboo board next
time now that QEMU's grown more support for ppc440...)

And so, I cut a release.  Tagged commit 1375, uploading the 8 gazillion
binary tarballs and the source tarball as we speak.  I'll have to do
proper release notes and update the website tomorrow.


More information about the Aboriginal mailing list