[Aboriginal] Build error

Rob Landley rob at landley.net
Sat Oct 15 21:52:40 PDT 2011

On 10/09/2011 08:30 AM, prasanna balan wrote:
> On Sat, Oct 8, 2011 at 11:09 PM, Rob Landley <rob at landley.net> wrote:
>> On 10/06/2011 11:49 PM, prasanna balan wrote:
>>> On 7 Oct 2011 03:27, "Rob Landley" <rob at landley.net
>>> <mailto:rob at landley.net>> wrote:
>>>> On 10/06/2011 09:18 AM, prasanna balan wrote:
>>>>> I tried building aboriginal 1.1.0 and it broke during uClibc++ native
>>>>> compiler...The last few lines of the build are as below:
>>>> You just ran ./build.sh i686?
>>> Forgot to mention. It was. /build.sh i686
>> That's why the build outputs stuff like:
>>>>> === ccwrap (i686 native-compiler)
>> Identifying what it's currently doing.  Part of the question was "did
>> you run stages individually", "did you change lots of config" knobs,
>> "did you skip host-tools.sh"...  the usual.  Your answer implies "no" to
>> all that.
>>> I tried with NO_CPLUSPLUS =1 and it built without break means some issue
>>> with uclibc++ exists.
>>> I use 32 bit slackware current with ext4 fs on /home
>> I downloaded the slackware DVD and the kernel kept panicing when booted
>> from the DVD under virtualbox on my work machine.  I'm trying again on
>> my netbook but it's a longish download...

It took a long time to download, install, and run the build on my
netbook, but it went a lot faster when I transferred the image off my
little netbook and onto the server upstairs.

I did a default install from the dvd, wget the most recent release of
the source, extracted it, did "./build.sh i686".  It built to completion.

I need more information to reproduce this problem.  What filesystem are
you using on /home?

>> Rob
> I tried it again and it broke again with the same errors (that's
> obvious)..This time I ran more/record-commands.sh and redid the build.
> Details are as below:
> ===================================================
> $ cat build/logs/cmdlines.i686.native-compiler.uClibc++
> make "defconfig"
> gcc "-Os" "-S" "-o" "/dev/null" "-xc" "/dev/null"
> gcc "-print-libgcc-file-name"
> cut "-c1"
> gcc "-dumpversion"
> grep "-q" "as-needed"
> ld "--help"
> cut "-c1"
> gcc "-dumpversion"
> make "-C" "extra/config" "conf"
> $

Um, that's odd.  It should show you the commands "make" is running.
(Did the build reset the $PATH somehow?)  That...

Oh.  Hang on,  Do this:

  export -p | grep PATH=

Is your $PATH exported? If it's just a local variable, that could
explain what you're seeing.  (And I can fix that in sources/include.sh
actually, I just haven't hit this particular environmental weirdness
before.  Well, not in this context, anyway.)

> ==================================================
> This specifically means that the recursive make breaks due to some
> unknown reason.Hope this helps in debugging.

It means that recursive make stops logging, which implies that the $PATH
is no longer pointing to the logging wrapper directory.

Except that include/functions.sh is exporting the PATH when it modifies
it while setting the architecture.  Hmmm...

Can you run make with -d maybe?



More information about the Aboriginal mailing list