[Aboriginal] Build error

prasanna balan prazzb at gmail.com
Sun Oct 9 06:30:42 PDT 2011

On Sat, Oct 8, 2011 at 11:09 PM, Rob Landley <rob at landley.net> wrote:
> On 10/06/2011 11:49 PM, prasanna balan wrote:
>> On 7 Oct 2011 03:27, "Rob Landley" <rob at landley.net
>> <mailto:rob at landley.net>> wrote:
>>> On 10/06/2011 09:18 AM, prasanna balan wrote:
>>> > I tried building aboriginal 1.1.0 and it broke during uClibc++ native
>>> > compiler...The last few lines of the build are as below:
>>> You just ran ./build.sh i686?
>> Forgot to mention. It was. /build.sh i686
> That's why the build outputs stuff like:
>>> > === ccwrap (i686 native-compiler)
> Identifying what it's currently doing.  Part of the question was "did
> you run stages individually", "did you change lots of config" knobs,
> "did you skip host-tools.sh"...  the usual.  Your answer implies "no" to
> all that.
>> I tried with NO_CPLUSPLUS =1 and it built without break means some issue
>> with uclibc++ exists.
>> I use 32 bit slackware current with ext4 fs on /home
> I downloaded the slackware DVD and the kernel kept panicing when booted
> from the DVD under virtualbox on my work machine.  I'm trying again on
> my netbook but it's a longish download...
> Rob

I tried it again and it broke again with the same errors (that's
obvious)..This time I ran more/record-commands.sh and redid the build.
Details are as below:

$ cat build/logs/cmdlines.i686.native-compiler.uClibc++
make "defconfig"
gcc "-Os" "-S" "-o" "/dev/null" "-xc" "/dev/null"
gcc "-print-libgcc-file-name"
cut "-c1"
gcc "-dumpversion"
grep "-q" "as-needed"
ld "--help"
cut "-c1"
gcc "-dumpversion"
make "-C" "extra/config" "conf"
This specifically means that the recursive make breaks due to some
unknown reason.Hope this helps in debugging.



More information about the Aboriginal mailing list