[Aboriginal] m68k support and qemu-1.6

Rob Landley rob at landley.net
Tue Oct 1 08:44:13 PDT 2013

On 10/01/2013 06:21:40 AM, Patrick Lauer wrote:
> Hi all,
> I noticed that the available m68k targets apparently changed in  
> qemu-1.6.
> The current command in sources/targets/m68k
> is:
> qemu-system-m68k -M q800

That's for Laurent Vivier's m68k branch adding support for the last  
m68k macintosh. Unfortunately, it's been half-finished forever. Last I  
checked the MMU part of CPU support wasn't there, and the kernel worked  
up until it tried to enable the page tables, then paniced.

> I suggest changing it to:
> qemu-system-m68k -M an5206

That's a coldfire board:


Coldfire is a nommu subset of m68k. Can you plug a real 68030 into it?

> Support is still quite fragile - trying to start the m68k image I get:
> $ ./run-emulator.sh
> qemu: fatal: Illegal instruction: 60ff @ 00002000

Because coldfire isn't full m68k.

The image partially works with the q800 branch of  
git://gitorious.org/qemu-m68k/qemu-m68k but full support was never  
there in qemu. (There's another emulator, aranym, that emulates atari  
boards. The aboriginal userspace was made to work under that, with a  
different kernel .config, but it doesn't provide all the I/O devices we  
needed to do an automated linux from scratch build with the current  
setup. We could presumably do one by hand...)


More information about the Aboriginal mailing list