[Aboriginal] Time for another release.

David Halls dahalls at gmail.com
Fri Jul 24 00:35:43 PDT 2015

Thanks for the update Rob.
What's the issue with x86_64?

On 23 July 2015 at 04:52, Rob Landley <rob at landley.net> wrote:

> Bit past due, really.
> I got the sh2eb and sh2elf binflt toolchains working. Userspace isn't
> yet because nommu, I tried switching ash out for hush but it still needs
> fork(). (CONFIG_MSH is aliased to CONFIG_HUSH, so they yanked the shell
> that worked nommu and replaced it with one that didn't.)
> I'm debugging why awk is breaking on mips: "awk '{print $2}' blah.txt"
> is hanging because the "2" parses as NAN and it loops, which turns out
> to be a kernel bug introduced by 46490b572544 which was _not_ fixed by
> backporting 620b15503457.
> There's also something funky with i686 and x86_64 builds under qemu, but
> I can just do those in a chroot for the moment. Not sure I'm holding up
> the release for that.
> Rob
> _______________________________________________
> Aboriginal mailing list
> Aboriginal at lists.landley.net
> http://lists.landley.net/listinfo.cgi/aboriginal-landley.net
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.landley.net/pipermail/aboriginal-landley.net/attachments/20150724/48f6584b/attachment-0001.htm>

More information about the Aboriginal mailing list