[Aboriginal] Time for another release.

Rob Landley rob at landley.net
Fri Jul 24 02:04:34 PDT 2015

The x86_64 issue is actually two issues.

1) distcc is hanging. I have no idea why. I've tried to trace into it
but distcc such a mess I'm pretty sure it would be easier to write a
replacement (adding distcc functionality to ccwrap is on the todo list)
than fix it.

2) Unfortunately, if I disable distcc then qemu's floating point
emulation isn't quite right, and gets one of those "failure to compare
zero equal to zero" things, specifically:


Of course it's deep in the bowels of the perl build. It works fine if
you run it in a chroot, so it's not a userspace issue. And I've reverted
the kernel back _two_years_ and it's still doing it, so it's not a
kernel issue. Pretty sure the x86_64 build was only tested under distcc
for a long time until it stopped working, so the code was built by the
host compiler that resolved constants using the host's FPU which did the
floating point calculation right. (I.E. this never worked in qemu.) So
maybe a qemu upgrade broke this, but not a remotely recent one. (I think
what broke distcc was me upgrading my _host_ from ubuntu 12.04 to 14.04.
Considering I'm building my distcc binaries from the same source in
host-tools.sh and on the target, that means it's probably a host glibc
version upgrade screwing up distccd on the host since host-tools is
built with host toolchain against host libc...)

I could try to isolate the breakage and feed a bug report to the qemu
guys, or I could write my own distcc replacement. But it's so easy to
work around (more/chroot-setup.sh) I haven't bothered yet.


On 07/24/2015 02:35 AM, David Halls wrote:
> Thanks for the update Rob.
> What's the issue with x86_64?
> On 23 July 2015 at 04:52, Rob Landley <rob at landley.net
> <mailto:rob at landley.net>> wrote:
>     Bit past due, really.
>     I got the sh2eb and sh2elf binflt toolchains working. Userspace isn't
>     yet because nommu, I tried switching ash out for hush but it still needs
>     fork(). (CONFIG_MSH is aliased to CONFIG_HUSH, so they yanked the shell
>     that worked nommu and replaced it with one that didn't.)
>     I'm debugging why awk is breaking on mips: "awk '{print $2}' blah.txt"
>     is hanging because the "2" parses as NAN and it loops, which turns out
>     to be a kernel bug introduced by 46490b572544 which was _not_ fixed by
>     backporting 620b15503457.
>     There's also something funky with i686 and x86_64 builds under qemu, but
>     I can just do those in a chroot for the moment. Not sure I'm holding up
>     the release for that.
>     Rob
>     _______________________________________________
>     Aboriginal mailing list
>     Aboriginal at lists.landley.net <mailto:Aboriginal at lists.landley.net>
>     http://lists.landley.net/listinfo.cgi/aboriginal-landley.net

More information about the Aboriginal mailing list