[Aboriginal] Bug report for lfs-bootstrap

Rob Landley rob at landley.net
Thu Mar 19 14:01:23 PDT 2015

On 03/18/2015 05:10 PM, Avery Payne wrote:
> On 3/11/2015 8:37 PM, Rob Landley wrote:
>>> I would like to do something that will seem a bit odd to you but makes
>>> sense for my purposes.  I would like to use Aboriginal to bootstrap a
>>> bespoke installation - basically, my own personal distro.
>> Not odd at all. This is why the build control images exist:
>> http://landley.net/aboriginal/control-images
>> The lfs-bootstrap one builds linux from scratch (6.8) under aboriginal.
> Not entirely sure why the probe is failing on but I thought I would at
> least report it.
> I've had no luck in getting the current lfs-bootstrap image to build. 
> The version of grep in the current release is the culprit, with the
> message halting on a check for "support for -e and long lines" in the
> middle of a ./config or autoconfig or whatever it is.


Ah! The downloads/binaries symlink pointed to 1.2.9, not 1.4.0. It was two
releases back. Yeah, that'll screw stuff up. :) (And since "bin" points
through downloads/binaries, it was going the wrong place too.)

Fixed it, let me try...

  mkdir temp
  cd temp
  wget http://landley.net/aboriginal/control-images/downloads/binaries/lfs-bootstrap.hdc
  wget http://landley.net/aboriginal/bin/system-image-i686.tar.gz
  tar xvzf system-image-i686.tar.gz
  cd system-image-i686
  ./native-build.sh ../lfs-bootstrap.hdc

There are four things it helps to have in the $PATH on the host. (Well, 5
counting the right qemu-system binary.)

1+2) toybox and busybox (it uses toybox netcat and busybox ftpd. I need
to clean up and promote toybox ftpd...)

3+4) i686-cc and distccd (to use distcc acceleration with the cross
compiler; the scripts will set it up but only if the tools are found.)

> I tried building
> some other stuff I pulled from elsewhere and also ran into the same
> "support for -e and long lines" issue.  Looking up the "-e" flag, it's
> supposed to be the expression to match against, so unless the error
> isn't stating itself correctly, that leaves the concept of "long lines"
> as the culprit for the failure, whatever the heck that means.

Leftover bug in the 1.2.9 release. Long since fixed. Sorry about that.

I sat around watching it build until it made it to coreutils (package 13
of 48, I love the title bar updating progress indicator trick). If you
still have problems, let me know.



More information about the Aboriginal mailing list